This is a really interesting point as we were looking at how to model Telephone Numbers and the only things i could find from TMF were the
'Information_Framework_SIF_Excel_Formatv21.0' and this https://projects.tmforum.org/wiki/pages/worddav/preview.action?fileName=GB922_Resource_Order_Portability_R17.5.1.docx&pageId=88576606
"This new entity called ResourceNumber exists not to only manage the specification, but to associate it with portability. The number is a very complex and broad entity, with specific things like format, ranges, area code and other characteristics for the number that vary for each country. Its purpose is to fill the number specification according to Number Portability, but it can be used for number inventory. The association with NumberPortability is to one and many, since a number can have many ports and a port can happen to a specific number. Nevertheless, they are already related through the order, for that reason the relationship they have is derived. Both, ResourceNumber and ResourceNumberSpecification, inherit from existing entities, LogicalResourceSpec (from LogicalResource Specification ABE) and LogicalResource (from LogicalResource ABE)."
Both of these suggest a subclass of logical resource called 'ResourceNumber' with a strongly typed attribute 'dialedNumber'. Is this not the TMF defined best practice?Also we have had some inconsistent naming accross legacy data model implementations and therefore wanted to centre on a common and single way of naming this entity attribute (TelephoneNumber, TerminatingNumber, DirectoryNumber, CLI).I took it from this documentation that TMF were setting out that best practice is to call it 'dialedNumber', could anyone help confirm or challenge this understanding?