Open APIs

Expand all | Collapse all

Working Environment File and Postman version V1 compatibility issue

  • 1.  Working Environment File and Postman version V1 compatibility issue

    TM Forum Member
    Posted May 20, 2021 07:44
    Edited by Rohit Goyal May 20, 2021 07:45
    Hi Members,

    In past, I was able to work with the environment file available on GitHub and JSON file available in the OPEN API Table and execute them.

    Today when i cleaned my postman workspace and trying to re-setup the environment and execute latest API , I am getting error.

    Issues are
    1)  Environment Files on GitHub are 6 years old

    tmforum/TMFAPIPOSTMAN
    2) The postman files available in Open API table are V1 which are not longer supported by Postman
    Open API Table

    Please advice







    Thanks and Regards,
    Rohit

    ------------------------------
    Rohit Goyal
    Infosys
    ------------------------------


  • 2.  RE: Working Environment File and Postman version V1 compatibility issue

    TM Forum Member
    Posted May 20, 2021 10:36
    Hello Rohit Goyal.

    We are aware of this issue, we will release v2.1 Postmans only from now on.

    For old environments I recommend that you convert them using the tool provided by Postmanlabs:

    https://github.com/postmanlabs/postman-collection-transformer

    I will check with the team about doing this for old collections.

    ------------------------------
    Henrique Rodrigues
    TM Forum
    ------------------------------



  • 3.  RE: Working Environment File and Postman version V1 compatibility issue

    TM Forum Member
    Posted May 20, 2021 10:44
    Thanks Henrique Rodrigues.

    I did give a try to https://github.com/postmanlabs/postman-collection-transformer but could not succeed.

    I am using Windows 10 Laptop. If you have steps for windows 10, please share.

    Thanks and Regards,
    Rohit

    ------------------------------
    Rohit Goyal
    Infosys
    ------------------------------