Open APIs

  • 1.  BillingAccount missing parameter "ratingType" in TMF666 v4.0.0

    TM Forum Member
    Posted May 15, 2020 09:23
    Pardon if I have misunderstood or post this question the wrong place.

    The entity BillingAccount has a parameter called ratingType in the data model at https://github.com/tmforum-rand/schemas/blob/candidates/Customer/BillingAccount.schema.json and in the PDF documentation for Account Management API REST Specification, Release 19.0, Version 4.0.1

    But I cannot find the same parameter in the swagger file for BillingAccount and BillingAccount_Update at https://github.com/tmforum-apis/TMF666_AccountManagement/blob/1e039134950afae396940c1a0f34187746f327f4/TMF666-Account-v4.0.0.swagger.json#L4150 and https://github.com/tmforum-apis/TMF666_AccountManagement/blob/1e039134950afae396940c1a0f34187746f327f4/TMF666-Account-v4.0.0.swagger.json#L4354

    Error in the swagger file or something I'm missing?

    ------------------------------
    Peter Magnus Prestesæter
    Telia Company
    ------------------------------


  • 2.  RE: BillingAccount missing parameter "ratingType" in TMF666 v4.0.0

    TM Forum Member
    Posted May 17, 2020 01:40
    Hi Peter
    It does appear that there is a problem. In our most up-to-date schema file Billing Account indeed has ratingType attribute, but it is missing from the published Swagger.
    I have opened a defect report, cannot promise when this will be addressed.
    Thanks for your alertness

    ------------------------------
    Jonathan Goldberg
    Amdocs Management Limited
    Any opinions and statements made by me on this forum are purely personal, and do not necessarily reflect the position of the TM Forum or my employer.
    ------------------------------



  • 3.  RE: BillingAccount missing parameter "ratingType" in TMF666 v4.0.0

    TM Forum Member
    Posted 27 days ago
    Hi Jonathan,

    do you know the status of this issue? Apparently is still not fixed.

    Thanks,
    Miguel Leal

    ------------------------------
    Miguel Leal
    Nokia
    ------------------------------



  • 4.  RE: BillingAccount missing parameter "ratingType" in TMF666 v4.0.0

    TM Forum Member
    Posted 27 days ago
    Hi Miguel
    I'm really sorry (and embarrassed) to report that the issue is still open. It seems like we have gaps in our governance process :( .
    I'll try to highlight this issue in our upcoming governance call this Wednesday.

    ------------------------------
    Jonathan Goldberg
    Amdocs Management Limited
    Any opinions and statements made by me on this forum are purely personal, and do not necessarily reflect the position of the TM Forum or my employer.
    ------------------------------